[gmx-users] does not appear to contain CMakeLists.txt Error to compile GROMACS 4.6.3

Justin Lemkul jalemkul at vt.edu
Tue Jul 22 18:48:17 CEST 2014

On 7/22/14, 12:25 PM, leila salimi wrote:
> Dear GROMACS Users,
> I tried to compile GROMACS on my computer, I did a quick installation as I
> saw in the link
>   tar -xvzf gromacs-4.6.1.tar.gz
>   $ cd gromacs-4.6.1
>   $ mkdir build
>   $ cd build
> ( I did not have cmake and I got it form " sudo apt-get install cmake " in
> build folder, then I tried the next line)
>   $ cmake .. -DGMX_BUILD_OWN_FFTW=ON
>   $ cmake ..

What did these two commands produce?  Did you invoke them one after another, or 
did you clean the build directory between them (as you should have done)?

> I tried to   sudo make install and I got the error
> CMake Error: The source directory
> "/fs01/ma05/homes/salimi/Programs/gromacs-4.6.3" does not appear to contain
> CMakeLists.txt.
> Specify --help for usage, or press the help button on the CMake GUI.
> make: *** [cmake_check_build_system] Error 1

This error shouldn't be triggered by "sudo make install," but would show up when 
invoking cmake.

> Althogh I have the CMakeLists.txt in the source path
> "/fs01/ma05/homes/salimi/Programs/gromacs-4.6.3"
> Do you know what it is wrong with this installation?

Sounds a bit hard to believe, but in any case, install the latest version (4.6.6 
in the 4.6.x series, or 5.0 otherwise) and try again.



Justin A. Lemkul, Ph.D.
Ruth L. Kirschstein NRSA Postdoctoral Fellow

Department of Pharmaceutical Sciences
School of Pharmacy
Health Sciences Facility II, Room 601
University of Maryland, Baltimore
20 Penn St.
Baltimore, MD 21201

jalemkul at outerbanks.umaryland.edu | (410) 706-7441


More information about the gromacs.org_gmx-users mailing list