[gmx-users] help with g_puckering

Justin Lemkul jalemkul at vt.edu
Wed Mar 5 19:59:43 CET 2014

On 3/5/14, 1:22 PM, cesteban at unsl.edu.ar wrote:
> Hi all
> I tried to use the program g_puckering and I had trouble compiling. I am
> using Gromacs 4.5.3 (linux CENTOS 6.2) and I have tried to install the
> analysis-tool g_puckering_gmx4_0_x.
> I followed the instructions of the README help:
> - Adjust the LDFLAGS and INCLUDES in the Makefile.tmpl
>    matching to your location of gromacs and X11.
> - run make
> At this stage the following error appears:
> for i in build src; do make -C $i all; done
> make[1]: Entering directory `/home/adrian/g_puckering/build'
> make[1]: Nothing to be done for `all'.
> make[1]: Leaving directory `/home/adrian/g_puckering/build'
> make[1]: Entering directory `/home/adrian/g_puckering/src'
> gcc -g -O3 -fomit-frame-pointer -finline-functions -Wall -Wno-unused
> -malign-double -funroll-all-loops -I/usr/include -I/usr/include/libxml2
> -I/share/apps/gromacs453/include/gromacs -c g_puckering.c
> make[1]: Leaving directory `/home/adrian/g_puckering/src'
> Please, could anyone guide me how to proceed with the installation of the
> program?

You're trying to compile an outside piece of software designed for a (very) old 
version of Gromacs by using a (less) old version.  If g_puckering was designed 
for 4.0.x, it relies on the code structure of 4.0.x, so using 4.5.x or newer is 
certain to fail unless you fix the code.



Justin A. Lemkul, Ph.D.
Ruth L. Kirschstein NRSA Postdoctoral Fellow

Department of Pharmaceutical Sciences
School of Pharmacy
Health Sciences Facility II, Room 601
University of Maryland, Baltimore
20 Penn St.
Baltimore, MD 21201

jalemkul at outerbanks.umaryland.edu | (410) 706-7441


More information about the gromacs.org_gmx-users mailing list