[gmx-users] QM / MM assistance

Justin Lemkul jalemkul at vt.edu
Sun Sep 14 19:15:10 CEST 2014

On 9/14/14 12:59 PM, Eric Smoll wrote:
> Hello Johnny,
> Thanks for the suggestion. I dumped the contents of CMakeError.log below. I
> am not sure why the C compiler failed. The error occurs on directory
> change? Later in the log, libmopac.a fails. Is this a static/shared problem?

What is your full cmake command?  Do you have to do anything special to 
configure your environment (module loading, etc)?

> This page (http://wwwuser.gwdg.de/~ggroenh/qmmm.html) contains the
> following instructions. "Compile all mopac files (f77 -O2 -c *.f), except
> mopac.f, moldat.f and deriv.f (thes ones are to be replaced by gmxmop.f),
> and collect the objects (*.o) into a library (ar rcv libmopac.a *.o;ranlib
> libmopac.a). Or if you are using linux, simply download libmopac.a
> instead." libmopac.a is not working for me. mopac.f is not
> in mopac7-1.11/fortran. Should I ignore its absence or
> replace mopac7app.f and mopac7lib.f instead?

The main problem here is you're trying to follow instructions designed for 
10-year-old software on the current version.  I would expect it to fail.  The 
QM/MM interface is largely unmaintained.  It has been slated for a complete 
re-write for years, but it hasn't been finished.  ORCA should compile (I fixed a 
few random bugs related to that a while back), but beyond that, I have no idea. 
  FWIW, I tried Mopac years ago and it never worked.  That was in the 4.0.x series.



Justin A. Lemkul, Ph.D.
Ruth L. Kirschstein NRSA Postdoctoral Fellow

Department of Pharmaceutical Sciences
School of Pharmacy
Health Sciences Facility II, Room 601
University of Maryland, Baltimore
20 Penn St.
Baltimore, MD 21201

jalemkul at outerbanks.umaryland.edu | (410) 706-7441


More information about the gromacs.org_gmx-users mailing list