[gmx-users] forcefield error for atoms

mah maz mahmaz71 at gmail.com
Sun Apr 5 07:03:00 CEST 2015

Thanks Justin! my system is a CNT but I need to insert some atoms in it
with no bonds. The best way I found is to make a .pdb and .gro files of the
newly constructed system and then without the use of g_x2top command, I
added anything needed to the .top file which was made previously without
the inserted atoms for the pure CNT system. changes in the .n2t file were
also considered including atom introduction. It worked!

On Thu, Mar 26, 2015 at 1:34 PM, mah maz <mahmaz71 at gmail.com> wrote:

> Hi Justin,
> Thank you! I checked the coordinates and I think there's nothing wrong
> with them. The problem might be from the .n2t file. I have some atoms
> without any bonds to other atoms in my system. So, in the .n2t file I
> assign 0 for bonds to other atoms. And it again stops with the same error
> while making the topology file. How can I get rid of this error?
> Cheers!
> On Tue, Mar 24, 2015 at 9:00 PM, mah maz <mahmaz71 at gmail.com> wrote:
>> Hi Justin,
>> Thanks for your reply. As you guessed correctly, for making a topology
>> file I used "g_x2top -f  file.gro -o file.top -ff forcefield -noparam".
>> I have a CNT system and I thought I should use g_x2top instead of
>> pdb2gmx command. If I'm right, what may cause this error and what would be
>> the solution?
>> Thanks!
>> On Mon, Mar 23, 2015 at 12:41 AM, mah maz <mahmaz71 at gmail.com> wrote:
>>> Dear all,
>>> I need to insert some atoms (without any bonds to other atoms) or even
>>> ions in my system. I have created the .pdb, and .gro files, but when I
>>> try to generate the .top file it stops with the following error: "
>>> forcefield not found for atoms with 0 bonds". Is there a way to solve this
>>> problem?
>>> Thanks!

More information about the gromacs.org_gmx-users mailing list