[gmx-users] Error installing during CXX Executable stage

Vito Spadavecchio spadavecchio at gmail.com
Wed Aug 3 02:14:31 CEST 2016


On Ubuntu 16.04, I have tried cmake with the following command:


This process completes (with some warnings), and when you try to make, it
gets to the following stage and fails:

*[ 98%] Linking CXX shared library ../../lib/libgromacs_mpi.so*
*[ 98%] Built target libgromacs*
*Scanning dependencies of target template*
*[ 98%] Building CXX object
*[ 98%] Linking CXX executable ../../bin/template*
*/usr/lib/gcc/x86_64-linux-gnu/4.7/../../../../lib/libblas.so: undefined
reference to `gotoblas'*
*collect2: error: ld returned 1 exit status*
*share/template/CMakeFiles/template.dir/build.make:113: recipe for target
'bin/template' failed*
*make[2]: *** [bin/template] Error 1*
*CMakeFiles/Makefile2:1889: recipe for target
'share/template/CMakeFiles/template.dir/all' failed*
*make[1]: *** [share/template/CMakeFiles/template.dir/all] Error 2*
*Makefile:160: recipe for target 'all' failed*
*make: *** [all] Error *

I have a nvidia card installed, using cuda-8.0 toolkit, and gcc-4.7 and
g++-4.7, but also tried a gcc/g++ 4.9 combo, which also failed. Has anyone
else seen this issue?


More information about the gromacs.org_gmx-users mailing list