[gmx-users] Atom X in residue YYY was not found in rtp fil

Dawid das addiw7 at googlemail.com
Sat Feb 27 22:38:06 CET 2016

Dear Gromacs Experts,

I have created a new residue for which atom names in my *.pdb file are
4-signs long.
When I run gmx pdb2gmx I get following error

Fatal error:
Atom MCA in residue CH6 65 was not found in rtp entry CH6 with 33 atoms
while sorting atoms.

I am absolutely one hundred percent sure that I did not define atom called
There are atoms such as MCA1, MCA2, etc. in my *.rtp and other relevant
files. I think that the issue is related to the fact that in my *.pdb file,
the atom name
is now "glued" to residue name:

ATOM    478  N      CH6 A  65      11.385  68.446 -10.896 1.00
15.50           N
ATOM    479  MCA1CH6 A  65     10.237  67.920 -10.172 1.00 14.40           C
ATOM    480  MC1  CH6 A  65       9.431  69.147  -9.749  1.00
15.10           C

This is part of my *.pdb file. I know that it should not be a problem,
because *.pdb
files are read by positions, like *.gro files, but I cannot see any other

On the other hand, I have already worked with similar system and I did not
such an issue.

Could you give a hand or a tip with this one, please?

I use Gromacs 5.0.4

Best regards,
Dawid Grabarek

More information about the gromacs.org_gmx-users mailing list