[gmx-users] gmx insert-molecules not inserting molecules

Souparno Adhikary souparnoa91 at gmail.com
Wed Sep 13 11:54:09 CEST 2017

We tried to simulate a small molecule using GROMACS. We generated the
topology file and the GROMACS coordinate file using the PRODRG server. We
optimized the molecule prior to generating topology using GAUSSIAN 09.

However, we tried to study the interaction between multiple copies of the
same molecule in a water box. We generated the PBC and water box
successfully and then we went on to using gmx insert-molecules to insert
multiple copies of the molecule in the waterbox. It yielded the following

Reading solute configuration
Containing 33766 atoms in 11201 residues
Reading molecule configuration
Containing 166 atoms in 1 residues
Initialising inter-atomic distances...

WARNING: Masses and atomic (Van der Waals) radii will be guessed
         based on residue and atom names, since they could not be
         definitively assigned from the information in your input
         files. These guessed numbers might deviate from the mass
         and radius of the atom type. Please check the output
         files if necessary.

NOTE: From version 5.0 gmx uses the Van der Waals radii
from the source below. This means the results may be different
compared to previous GROMACS versions.

A. Bondi
van der Waals Volumes and Radii
J. Phys. Chem. 68 (1964) pp. 441-451
-------- -------- --- Thank You --- -------- --------

Try 40
Added 0 molecules (out of 4 requested)
Writing generated configuration to g1new.gro

Output configuration contains 33766 atoms in 11201 residues

What could be the possible problem??? We used the gmx insert-molecules as:

gmx insert-molecules -f mol1wt.gro -ci mol1_op.gro -o mol1new.gro -nmol 4

Souparno Adhikary,
Department of Microbiology,
University of Calcutta.

More information about the gromacs.org_gmx-users mailing list