[gmx-users] printf + trjcat

Hector Martinez-Lopez hector at mindthebyte.com
Fri Jan 26 09:47:50 CET 2018

Hey! I'm trying to use


printf "c\nc\nc" | trjcat -f 1.trr 2.trr 3.trr -o all.trr -settime


without results. I readed in other threads, here at the list, that it can be used as:


trjcat -f 1.trr 2.trr 3.trr -o all.trr -settime <<EOF






and it worked for me, also that can be used as


trjcat -f 1.trr 2.trr 3.trr -o all.trr -settime < three_c.txt


but this didn't worked for me.

So, I'm wondering why we can't use | (pipe) with printf on trjcat, while we can use them with solvate or other tools.

Also, can I fill an issue requesting trjcat to work with printf or to have a variable in which we can dump the letters for the -settime?

Thank you!


Hector Martinez-Lopez, BSc

Scientific Software Developer

hector at mindthebyte.com<mailto:hector at mindthebyte.com> | T. +34 934020938 - +45 39178231<https://www.linkedin.com/in/hectormarlo/>



Mind the Byte SL | Barcelona Science Park | C/ Baldiri Reixac, 4-8 | 08028

Mind the Byte ApS | Copenhagen Bio Science Park | Ole Maaløes Vej 3 | DK-2200 Copenhagen N

www.mindthebyte.com<http://www.mindthebyte.com> | [1499088055038_twitter.png]  @mindthebyte<https://twitter.com/mindthebyte>

More information about the gromacs.org_gmx-users mailing list