[gmx-users] gmx convert-tpr tool is not found but tpbconv_mpi is present in gromacs 5.0.4

Santanu Santra santop420 at gmail.com
Fri Jul 6 17:58:17 CEST 2018

Hi all,
         I have installed gromacs 5.0.4 in a parallel cluster. While I was
serching for gmx convert-tpr tool to extend my simulation that has been run
previously upto 15 ns (I want to continue the simulation upto 100 ns).
According to gromacs documentation tpbconv_mpi tool is removed from gromacs
5.0.xxxx version and this is replaced by gmx convert-tpr tool. But in my
bin directory there is nothing in the name of  gmx convert-tpr or in
similar name, but I found tpbconv_mpi . I also tried with that tool to
extend but it is showing error .

I tried the command======================
tpbconv_mpi -s md_nvt -o md_nvt_25.tpr -extend 10000
I got ====================================
GROMACS:      gmx tpbconv, VERSION 5.0.4
Executable:   /opt/gromacs-5.0.4/bin/gmx_mpi
Library dir:  /opt/gromacs-5.0.4/share/gromacs/top
Command line:
  tpbconv_mpi -s md_nvt -o md_nvt_25.tpr -extend 10000

This tool has been removed from Gromacs 5.0. Please see
for ideas how to perform the same tasks with the new tools.

I am confused with two contrary statements.....
(1) If tpbconv_mpi tool is removed from gromacs 5.0.X version, then how it
is present in my bin directory and also it is not working
(2) why  gmx convert-tpr tool is absent in my bin directory. As all other
tools are available in my bin directory.

Any help or suggestion is highly accepted. Thanks in advance.

More information about the gromacs.org_gmx-users mailing list