[gmx-users] gmx convert-tpr tool is not found but tpbconv_mpi is present in gromacs 5.0.4

Justin Lemkul jalemkul at vt.edu
Fri Jul 6 19:57:25 CEST 2018

On 7/6/18 11:58 AM, Santanu Santra wrote:
> Hi all,
>           I have installed gromacs 5.0.4 in a parallel cluster. While I was
> serching for gmx convert-tpr tool to extend my simulation that has been run
> previously upto 15 ns (I want to continue the simulation upto 100 ns).
> According to gromacs documentation tpbconv_mpi tool is removed from gromacs
> 5.0.xxxx version and this is replaced by gmx convert-tpr tool. But in my
> bin directory there is nothing in the name of  gmx convert-tpr or in
> similar name, but I found tpbconv_mpi . I also tried with that tool to
> extend but it is showing error .
> I tried the command======================
> tpbconv_mpi -s md_nvt -o md_nvt_25.tpr -extend 10000
> ============================================
> I got ====================================
> GROMACS:      gmx tpbconv, VERSION 5.0.4
> Executable:   /opt/gromacs-5.0.4/bin/gmx_mpi
> Library dir:  /opt/gromacs-5.0.4/share/gromacs/top
> Command line:
>    tpbconv_mpi -s md_nvt -o md_nvt_25.tpr -extend 10000
> This tool has been removed from Gromacs 5.0. Please see
>    http://www.gromacs.org/Documentation/How-tos/Tool_Changes_for_5.0
> for ideas how to perform the same tasks with the new tools.
> =======================================================
> I am confused with two contrary statements.....
> (1) If tpbconv_mpi tool is removed from gromacs 5.0.X version, then how it
> is present in my bin directory and also it is not working

Version 5.0 was a transitional version between "old" and "new" command 
syntax. If a user attempts to run tpbconv, they are greeted with this 
message, which tells them they need to update the scripts. You will note 
that the contents of your bin directory are all symlinks to the gmx 
binary, rather than standalone executables, like they once were.

> (2) why  gmx convert-tpr tool is absent in my bin directory. As all other
> tools are available in my bin directory.

You won't see anything named "convert-tpr," but you will see a binary 
called "gmx" (or maybe "gmx_mpi," as it appears your entire set of tools 
was compiled with MPI). Then invoke gmx convert-tpr, as the error 
message states.



Justin A. Lemkul, Ph.D.
Assistant Professor
Virginia Tech Department of Biochemistry

303 Engel Hall
340 West Campus Dr.
Blacksburg, VA 24061

jalemkul at vt.edu | (540) 231-3129


More information about the gromacs.org_gmx-users mailing list