[gmx-users] V2018.1 building issues

kevin chen fch6699 at gmail.com
Thu May 10 18:17:07 CEST 2018

Hi  Gromacs Users,

I'm having this weird issue while trying to build the new V2018.1 on
Stampede2, which has both SKX amd KNL nodes on it. For V2016 and older, in
order to run the same executable(mdrun_mpi), we have to build the "fat"
binary with " -DGMX_SIMD=AVX_512" and "-DCMAKE_C_FLAGS="-O3 -xCORE-AVX2
-axCORE-AVX512,MIC-AVX512 ". That actually worked just fine for V2016. We
can actually run simulation on both skx and knl without any issues using
the same binary. However, for some reason the same trick no longer works
with V2018.1. We tried to build V2018.1 with the exactly same building
script with " -DGMX_SIMD=AVX_512" option applied. This time around the
binary(mdrun_mpi) only works on skx node but no on knls. So I was wondering
is there any thing change since V2016 causing this issue or am I missing
anything here? Thanks advanced for any pointers you guys might provide.

Our building environment,

Currently Loaded Modules:
  1) intel/17.0.4   3) git/2.9.0       5) python/2.7.13   7) TACC
  2) impi/17.0.3    4) autotools/1.1   6) xalt/1.7.7      8) cmake/3.10.2



More information about the gromacs.org_gmx-users mailing list