[gmx-users] Problems installing gromacs 2019.1 using bash (ubunto 18.04) on a win10 PC

Fritjof Nilsson fritjofn at kth.se
Tue Mar 5 22:57:55 CET 2019

Problems installing gromacs 2019.1 using bash (ubunto 18.04) on a win10 PC

Dear email-list members, I have tried to install gromacs 2019.1 using bash (ubunto linux 18.04 is installed) on my windows 10 laptop (intel core i7-4810MX Cpu, 2.8GHz, 8Gb ram, 64 bit win 10). Before installation I put the gromacs 2019.1 tar-file in a folder called "Program paket", such that the path became "C:\Users\myname\Desktop\Program paket\gromacs-2019.1". I tried to run the following sequence of commands in the bash-shell:


$cd Desktop/Program\ paket

$tar xfz gromacs-2019.1.tar.gz

$cd gromacs-2019

$mkdir build

$cd build

$sudo apt-get update && sudo apt-get upgrade

$sudo apt-get install gcc

$sudo apt-get install cmake

$sudo apt-get install build-essential

$sudo apt-get install libfftw3-dev



$make check

sudo make install

source /usr/local/gromacs/bin/GMXRC

Unfortunately, halfway through the installation, when I run cmake with "-DGMX_FFT_LIBRARY=fftw3" (or fftpack), I get the error message below:



-- Atomic operations not found

-- Atomic operations not found

CMake Warning at cmake/ThreadMPI.cmake:130 (message):

  Atomic operations not found for this CPU+compiler combination.  Thread

  support will be unbearably slow: disable threads.  Atomic operations should

  work on all but the most obscure CPU+compiler combinations; if your system

  is not obscure -- like, for example, x86 with gcc -- please contact the



With fftw3, when I afterwards run the "make" and "make-check"-commands, I get an error containing "configure: error: unsafe src-dir value", which stops the sequence completely. With fftpack the "make" and "make-check" commands comes a bit longer, succeeding at least the first 40 tests out of 46, but still fails in the end. (The failing tests were regressiontests/simple, complex, kernel, freeenergy, rotation and essential dynamics.) Can it be the choice of installation path that causes the problems or what can it be? (One typical default path for various program files seem to be: C\Users\myname\AppData\Local).

If someone has a clue about how to solve the problem I would be grateful!

Best regards, Fritjof Nilsson, KTH

More information about the gromacs.org_gmx-users mailing list