[gmx-users] problem on a G3 (Gromacs 3.1 beta released)

nicolis at guideo.fr nicolis at guideo.fr
Wed Feb 20 11:55:06 CET 2002

Hello again.
As I wrote you, I installed the beta 3.1 on a G4 MacOSX with no problem. But now I compiled on a G3 with the same version of MacOSX and I get an "illegal instruction" when running mdrun. I have no error with editconf, pdb2gmx, grompp and g_sas so I guess that this could be an altivec enhanced code problem. I had no such error with the beta prerelease VERSION 3.0.99-20011116 on the G3 nor the G4.
The illegal instruction message appears just after the number of steps, when the first step should appear. I got the error for both steep and md (did not test the other integrators).
I tried to recompile with --disable-ppc-altivec but with same result (I noticed however that the -faltivec option is still used after the --disable-ppc-altivec. Is this normal?)

Thank you,


P.S. As for the g_sas, I downloaded the cvs tree and copied the dgsolv.dat in the top directory, g_sas works now, thank you.

More information about the gromacs.org_gmx-users mailing list