[gmx-users] problem on a G3 (Gromacs 3.1 beta released)

David van der Spoel spoel at xray.bmc.uu.se
Wed Feb 20 20:00:26 CET 2002

On Wed, 20 Feb 2002 nicolis at guideo.fr wrote:

>Hello again.
>As I wrote you, I installed the beta 3.1 on a G4 MacOSX with no problem. 
>But now I compiled on a G3 with the same version of MacOSX and I get an 
>"illegal instruction" when running mdrun. I have no error with editconf, 
>pdb2gmx, grompp and g_sas so I guess that this could be an altivec 
>enhanced code problem. I had no such error with the beta prerelease 
>VERSION 3.0.99-20011116 on the G3 nor the G4.
>The illegal instruction message appears just after the number of steps, 
>when the first step should appear. I got the error for both steep and md 
>(did not test the other integrators).
>I tried to recompile with --disable-ppc-altivec but with same result (I 
>noticed however that the -faltivec option is still used after the 
>--disable-ppc-altivec. Is this normal?)

Maybe the configure script generates a compiler flag that is G4 specific. 
Maybe you can check the configure script or Makefiles. I have no such 
machine here to check, but it seems from the configure script that there 
is something like -mcpu=    

>Thank you,
>P.S. As for the g_sas, I downloaded the cvs tree and copied the dgsolv.dat in the top directory, g_sas works now, thank you.
>gmx-users mailing list
>gmx-users at gromacs.org
>Please don't post (un)subscribe requests to the list. Use the 
>www interface or send it to gmx-users-request at gromacs.org.

Groeten, David.
Dr. David van der Spoel, 	Biomedical center, Dept. of Biochemistry
Husargatan 3, Box 576,  	75123 Uppsala, Sweden
phone:	46 18 471 4205		fax: 46 18 511 755
spoel at xray.bmc.uu.se	spoel at gromacs.org   http://zorn.bmc.uu.se/~spoel

More information about the gromacs.org_gmx-users mailing list