[gmx-users] binutils

Milton Taidi Sonoda msonoda at iqm.unicamp.br
Thu Feb 21 12:58:08 CET 2002

Thank you Erik Lindahl and Peter Tieleman 
for the sugestions about binutils.
I've tried to do what you have recommended,
to change the path order, but it doesn't work.
Insted I solved the problem changing the 
configure file in the line 4995. This is what I
have done:
original line
if { ac_try='$CC -c conftest.s'
my file
if { ac_try='/usr/local/bin/as conftest.s'
Which is exactly what you have recomended
but in a diferent way. I don't why it didn't work
in the first time. Maybe because the as doesn't
like the -c option.

Now I have a diferent problem. When I tried to 
run the make, it spits the following error messege
/tmp/ccOHiepv.s: Assembler messages:

and this one a lot of times with diferent number 102
/tmp/ccOHiepv.s:102: Error: suffix or operands invalid for `movups'

and at the end this one
*** Error code 1

Stop in /usr/local/gromacs/src/gmxlib.
*** Error code 1

Stop in /usr/local/gromacs/src.
*** Error code 1

Stop in /usr/local/gromacs/src.
*** Error code 1

Stop in /usr/local/gromacs.

Do you know what is happening
and how to solve this problem?
Thanx in advance
Milton Taidi Sonoda

On Wednesday 20 February 2002 14:46, you wrote:
> Milton Taidi Sonoda wrote:
> > Hi all
> > I'm a new on Gromacs.
> > I tried to install it in my FreeBSD 4.3 system
> > and the configure script complained about
> > the version of my binutils (v. 2.9). I've downloaded
> > and installed the binutils package (v. 2.10) avaiable on the
> > Gromacs webpage, and tried to run the configure
> > again, but it still complains about binutils' version.
> > Could anyone help me.
> Hi,
> Make sure that your new 'as' command is the first one in your path. Type
> 'as --version' and check! The most probable problem is that you have the
> old version in /usr/bin, and /usr/local/bin comes later in your path
> variable. Add /usr/local/bin to the beginning of the path and it should
> work.
> On the other hand, I don't think *BSD supports SSE instructions in the
> kernel yet, and in that case you might as well disable the x86 assembly
> loops.
> Cheers,
> Erik

More information about the gromacs.org_gmx-users mailing list