[gmx-users] error compiling on MacOSX

rams at poori.biochem.uiowa.edu rams at poori.biochem.uiowa.edu
Wed May 22 20:01:45 CEST 2002


I had the same problem! that was not a OSX-problem.  This is because I had 
installed g77 - from a website (I cant remember now) where there was dmg 
files for g77, RASTER3D, molmol etc..  

Installing that g77 ruins everything.  Installin g77 from fink did not 
make a difference.  I completely reformatted my disk, reinstalled the 
developer tools.   Installed fink.  Then fink install g77.  Then went and 
followed the OSX compilation suggestions in the web-page of gromacs and it 
worked like magic.

There is a website that says - 10 worst things to do to your MAC -OSX 
system.  One of them is installing the g77 from this site...


On Wed, 22 May 2002, Erik Lindahl wrote:

> Valentin Gogonea wrote:
> > Dear Gromacs users,
> >
> > I tried to compile version 3.1.3 on MacOSX. I got the following error. 
> > Can somebody suggest me what should I do to get it working?
> >
> > Thank you,
> >
> > Valentin
> This isn't a Gromacs problem, it's OS X's fault.
> If you don't believe me, just do a recursive grep in the gmx directory - 
> there isn't a single reference to "langinfo" :-)
> I'm actually visiting them in Cupertino next week to discuss this type 
> of problems with their OS, and how they can improve it...
> Nevertheless, I might be able to work around it; could you run 
> ./configure and send the output to a file? I.e,
> /path/to/bash ./configure >& config.stdout
> And send me that file, and config.log so I can see where it picks it up.
> Cheers,
> Erik
> _______________________________________________
> gmx-users mailing list
> gmx-users at gromacs.org
> http://www.gromacs.org/mailman/listinfo/gmx-users
> Please don't post (un)subscribe requests to the list. Use the 
> www interface or send it to gmx-users-request at gromacs.org.

S. Ramaswamy
Department of Biochemistry.
University of Iowa.

More information about the gromacs.org_gmx-users mailing list