[gmx-users] Installation problems on Mac OSX 10.2.6

Lynn F. Ten Eyck lteneyck at sdsc.edu
Fri May 23 21:28:01 CEST 2003

I downloaded the latest source files last night to install Gromacs 3.1.4.
I successfully installed fftw.  Then I hit a few problems . . .

1.  ./configure could not identify my system.  I went to ftp.gnu.org and
downloaded the latest versions of config.guess and config.sub, which
identified powerpc-apple-darwin6.6 (correct, the computer is a Powerbook

2.  After successful ./configure I tried make, which died in gmxlib with
the following:

cc -DHAVE_CONFIG_H -I. -I. -I../../src -I/usr/X11R6/include
-I../../include -DGMXLIBDIR=\"/usr/local/gromacs/share/top\" -O6
-fomit-frame-pointer -finline-functions -Wall -Wno-unused -no-cpp-precomp
-faltivec -mcpu=powerpc -fno-schedule-insns -c fnbf.c
-Wp,-MD,.deps/fnbf.TPlo -o fnbf.o
../../include/ppc_altivec.h: In function `set_non_java_mode':
../../include/ppc_altivec.h:60: argument 0 to built-in function
`vec_splat_u32' does not satisfy constraint A
make[3]: *** [fnbf.lo] Error 1

I could probably get around this error by turning off the vectorization,
but I suspect that would be a huge performance hit.

Has anybody else solved this problem?

Lynn Ten Eyck

Lynn F. Ten Eyck                        lteneyck at sdsc.edu
San Diego Supercomputer Center 0505     (858) 534-5141
University of California, San Diego     (858) 822-3610 (FAX)
9500 Gilman Drive
La Jolla, CA 92093-0505                 Office: 202 CRB

More information about the gromacs.org_gmx-users mailing list