[gmx-users] Installation problems on Mac OSX 10.2.6

Erik Lindahl lindahl at stanford.edu
Fri May 23 21:54:01 CEST 2003

Hi Lynn,

On Friday, May 23, 2003, at 12:26  PM, Lynn F. Ten Eyck wrote:

> I downloaded the latest source files last night to install Gromacs 
> 3.1.4.
> I successfully installed fftw.  Then I hit a few problems . . .
> 1.  ./configure could not identify my system.  I went to ftp.gnu.org 
> and
> downloaded the latest versions of config.guess and config.sub, which
> identified powerpc-apple-darwin6.6 (correct, the computer is a 
> Powerbook
> G4).

Good thinking - we've already updated these files in the 3.1.5_pre1 

> 2.  After successful ./configure I tried make, which died in gmxlib 
> with
> the following:
> cc -DHAVE_CONFIG_H -I. -I. -I../../src -I/usr/X11R6/include
> -I../../include -DGMXLIBDIR=\"/usr/local/gromacs/share/top\" -O6
> -fomit-frame-pointer -finline-functions -Wall -Wno-unused 
> -no-cpp-precomp
> -faltivec -mcpu=powerpc -fno-schedule-insns -c fnbf.c
> -Wp,-MD,.deps/fnbf.TPlo -o fnbf.o
> ../../include/ppc_altivec.h: In function `set_non_java_mode':
> ../../include/ppc_altivec.h:60: argument 0 to built-in function
> `vec_splat_u32' does not satisfy constraint A
> make[3]: *** [fnbf.lo] Error 1
> I could probably get around this error by turning off the 
> vectorization,
> but I suspect that would be a huge performance hit.
> Has anybody else solved this problem?

This is a bug in Apple's version of gcc that I have reported (and they 
confirmed it). You might want to download the 3.1.5_pre1 release from 
ftp.gromacs.org/pub/beta, or just remove the contents of the routine 
set_non_java_mode() - setting this flag only improves performance by a 
percent or so anyway.



More information about the gromacs.org_gmx-users mailing list