[gmx-users] Re: +AFs-gmx-users+AF0- libXm.so.1 Gromacs Help

Marco Möller moeller at mail.uni-mainz.de
Tue Mar 22 13:19:27 CET 2005


when I installed Gromacs on a DEBIAN Linux system running on Pentium4 I 
have had a similar problem, but do not remember the error message (the 
exact name oft the missing procedure) in detail. I think it has been 
something like +ACI-libXm.so.1+ACI-, too, which means, a procedure coded in a 
file called +ACI-libXm+ACI- is missing. I think Gentoo is based on Debian, so my 
hints might help You:

I searched the Debian installation package archiv for a file called 
+ACI-libXm+ACI-, and found it to be a part of the libXml package. So, after 
installing this libXml package everything worked fine.

I guess that this libXml package is part of the standard RedHat 
distribution and therefor the Gromacs developers do not recommend to 
install it explicitly. But, as this package is not part of the standard 
Debian base installation, You will have to add it to Your system. I 
remember, that You have to add the fftw and the libXml software to the 
DEBIAN base system to get everything run. But sorry, I do not remember 
the exact names and versions of the packages, I used. All in all I 
choosed the newest versions from the +ACI-stable+ACI- archiv and everything 
worked without further problems. You might want to add a x-window system 
and then the grace software for md-analysis, too, but the trajectory 
calculations itself runs without it already. If somebody is interested, 
I could post my detailed installation protocol, how to set up a 
spartanic Debian Linux (base) System and which packages (exact package 
names) minimum to add.
Good luck+ACE-

Marco M+APY-ller
University of Mainz, Germany

----- Original Message ----- 
From: +ADw-supakar+AEA-spymac.com+AD4-
To: +ADw-gmx-users+AEA-gromacs.org+AD4-
Cc: +ADw-supakar+AEA-sify.com+AD4-
Sent: Saturday, March 19, 2005 8:00 AM
Subject: +AFs-gmx-users+AF0- libXm.so.1 Gromacs Help

       could anybody help me +ACE-

       I have installed gromacs on IBM Power PC (64 bit) with Gentoo as 
OS but
when i try to run any command eg. luck / pdb2gmx the ERROR mesege shown 
is :

luck: error while loading shared libraries: libXm.so.1: cannot open 
shared object
file: No such file directory

I have also tried to recover by installing open motif 
lesstiff(lesstif-0.94.0) but it showed the same error .

gmx-users mailing list
Please don't post (un)subscribe requests to the list. Use the
www interface or send it to gmx-users-request+AEA-gromacs.org.

More information about the gromacs.org_gmx-users mailing list