[gmx-users] problem still lies regarding dssp

sangeeta kundu sangeeta0983 at yahoo.co.in
Mon Feb 12 10:55:48 CET 2007

Dear Abu and Mark, 
     You asked me, whether my computer is shared by many, it is not, I think the program was not hanged because while executing do_dssp -v as usual Gromacs output was given, 
  ":-)  G  R  O  M  A  C  S  (-:
              GROningen Mixture of Alchemy and Childrens' Stories
                            :-)  VERSION 3.3.1  (-:
      Written by David van der Spoel, Erik Lindahl, Berk Hess, and others.
       Copyright (c) 1991-2000, University of Groningen, The Netherlands.
             Copyright (c) 2001-2006, The GROMACS development team,
            check out http://www.gromacs.org for more information.
         This program is free software; you can redistribute it and/or
          modify it under the terms of the GNU General Public License
         as published by the Free Software Foundation; either version 2
             of the License, or (at your option) any later version.
                               :-)  do_dssp  (-:
Option     Filename  Type         Description
  -f       traj.xtc  Input        Generic trajectory: xtc trr trj gro g96 pdb
  -s      topol.tpr  Input        Structure+mass(db): tpr tpb tpa gro g96 pdb
  -n      index.ndx  Input, Opt.  Index file
-ssdump  ssdump.dat  Output, Opt. Generic data file
-map         ss.map  Input, Lib.  File that maps matrix data to colors
  -o         ss.xpm  Output       X PixMap compatible matrix file
 -sc     scount.xvg  Output       xvgr/xmgr file
  -a       area.xpm  Output, Opt. X PixMap compatible matrix file
 -ta    totarea.xvg  Output, Opt. xvgr/xmgr file
 -aa   averarea.xvg  Output, Opt. xvgr/xmgr file
      Option   Type  Value  Description
      -[no]h   bool     no  Print help info and quit
      -[no]X   bool     no  Use dialog box GUI to edit command line options
       -nice    int     19  Set the nicelevel
          -b   time      0  First frame (ps) to read from trajectory
          -e   time      0  Last frame (ps) to read from trajectory
         -dt   time      0  Only use frame when t MOD dt = first time (ps)
         -tu   enum     ps  Time unit: ps, fs, ns, us, ms or s
      -[no]w   bool     no  View output xvg, xpm, eps and pdb files
   -[no]xvgr   bool    yes  Add specific codes (legends etc.) in the output
                            xvg files for the xmgrace program
        -sss string   HEBT  Secondary structures for structure count
  I changed the permission of   dsspcmbi and dsspcmbi.exe  files , what else  I should do? I mean execpt these two files what are the other files that need change of permission now these two files has read, write, and executable permission, Mark suggested  me to call dssp "by hand", will you please explain in more detail?? In order to get taht particular coloured map what procedure should I  adopt??
"Naser, Md Abu " <mn2 at hw.ac.uk> wrote:
      Hi Sangeeta,

Let me ask you few questions in order to solve the problem.

Are you sure your do_dssp prog were running or it was hanged?
To make sure please try using verbose output using -v option.

Is your computer shared among too many people?

What is the file permission status of dssp?

To find out use: ls -l /directory/where/you/put/dssp

If you see any restricton to file permission change it to

chmod a+rx dssp

Hope this will help.

Abu Naser

School Of Life Sciences
Heriot-Watt University
Edinburgh EH14 4AS
Email: mn2 at hw.ac.uk
Phone: +44(0)1314518265
Fax : +44(0) 131 451 3009

-----Original Message-----
From: gmx-users-bounces at gromacs.org on behalf of sangeeta kundu
Sent: Fri 09/02/2007 10:13 AM
To: gmx-users at gromacs.org
Subject: [gmx-users] problem still lies regarding dssp

Dear All,
            I do not know whether I am interrupting you again and again by asking the same question, but I am helpless , I can not detect my fault, When I run the program DSSP it works fine, but while executing do_dssp or my_dssp (as suggested by Yang) the program seems to be never ending, intermediate files are prepared for some time, but I never got any .xpm files, I can not understand whether my system is not working, or I am making any mistake, but all the other programs of Gromacs like pdb2gmx, editconf , genbox, grompp, mdrun etc are going on successfully, problem lies only in case of dssp, I was suggested by Mark to try dssp independently on a single snapshot extracted from the trajectory,  I took the snapshot of the protein after 500ps  with the command trjconv -f md.xtc -s md.tpr -o time_500ps.pdb -dump 500
  (I think the command is correct, if not I earnestly request you to rectify my mistake), When I ran do_dssp on this single structure I waited for 3 days, but it did not finish and seems to be neverending, then I killed the program, In order to get that particular coloured plot of secondary structure vs time which method should I adopt? Seeking your help and thanks in advance.

 Here's a new way to find what you're looking for - Yahoo! Answers

gmx-users mailing list gmx-users at gromacs.org
Please don't post (un)subscribe requests to the list. Use the 
www interface or send it to gmx-users-request at gromacs.org.
Can't post? Read http://www.gromacs.org/mailing_lists/users.php

 Here’s a new way to find what you're looking for - Yahoo! Answers 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://maillist.sys.kth.se/pipermail/gromacs.org_gmx-users/attachments/20070212/43360ce3/attachment.html>

More information about the gromacs.org_gmx-users mailing list