[gmx-users] Energy minimization problem with Double precision and mpi

Josiah Zayner jz75596 at appstate.edu
Sat Jun 23 19:05:03 CEST 2007

Each time I try to run mdrun with double precision and more than one node, I
always receive some atom with infinite Fmax, no matter what I do, Always on
Step=0. The strangest thing is that it still attempts the minimization but
the values never change except for Dmax in a steepest descent. If I change
the coordinates of the atom that has the inf value another one has infinite
value and so on. I use lam/mpi, with the command 'mpirun -np 5 mdrun_d -v
-deffnm potd'. My double precision was configured with both --enable-mpi and
--enable-double. Here is a copy of the mdp file I use:

title			=   potd
cpp			=   /usr/bin/cpp
constraints		=   none
integrator		=   steep
nsteps			=   0  
ns_type			=   grid
nstcomm			=   1
nstlist			=   10
rlist			      =   1.4
coulombtype		      =   Shift
vdw_type			=   Shift
rcoulomb			=   1.2
rvdw				=   1.2
rcoulomb_switch		=   1.0
rvdw_switch			=   1.0
epsilon_r			=   6.0	
optimize_fft		=   yes

emtol			=   1000
emstep		=   0.01
nstcgsteep		=   100

It doesn't matter if it is in vaccum or water. I have minimized to an emtol
of 10 and mdrun_d still does not work. I am using gromacs 3.3.1. I have
tried changing or removing almost every value in the mdp file. I have tried
different pdb files. Tried using grompp and grompp_d. Tried with -sort
-shuffle and without. Is this another one of those compiler issues like
genion? Any help would be great.

    Josiah Zayner 

More information about the gromacs.org_gmx-users mailing list