[gmx-users] trjconv -pbc cluster with rhombic dodecahedron box

chris.neale at utoronto.ca chris.neale at utoronto.ca
Mon Nov 30 14:18:42 CET 2009

Hi Daniel, what Tsjerk has suggested is really the only way to go  
here. If your cluster is not whole in the first frame, you can do it  
this way:

1. use trjconv -pbc cluster to make your cluster whole in a frame near  
the start of your trajectory. If the first frame enters the infinite  
loop, then try the second frame, etc.

2. Make a new .tpr based on this clustered .gro

3. run trjconv -pbc nojump


--- original message ---

Hi Daniel,

This doesn't exactly answer your question, but if your vesicle is
whole at the start, can't you better keep it that way using -pbc
nojump? If necessary, you can also recenter afterwards.

Hope it helps,


On Mon, Nov 30, 2009 at 12:24 PM, Daniel Parton
<daniel.parton at bioch.ox.ac.uk> wrote:

[Hide Quoted Text]

I am running a coarse-grained simulation of a lipid vesicle (~70,000
particles), using a rhombic dodecahedron box to limit the amount of solvent
I require.  The vesicle (unsurprisingly) moves over the periodic boundaries
during the simulation.  Various analyses I am conducting require the vesicle
to be whole, so I have been trying to use trjconv with the -pbc cluster
option, selecting the lipids as the group to be clustered.  I am only
interested in the lipid behaviour, so I am using a trajectory with only the
lipids included.  However, at certain frames, the program seems to enter an
infinite loop, producing many lines of the following sort of information:

COM:   12.445     5.934    15.354  iter = 2359
COM:   12.675     6.135     3.094  iter = 2360
COM:   12.455     5.934    15.368  iter = 2361
COM:   12.686     6.131     3.116  iter = 2362
COM:   12.454     5.945    15.396  iter = 2363
COM:   12.720     6.168     3.176  iter = 2364
COM:   12.461     5.947    15.435  iter = 2365
COM:   12.731     6.174     3.221  iter = 2366
COM:   12.468     5.945    15.475  iter = 2367
COM:   12.723     6.172     3.247  iter = 2368

This is using gromacs version 3.2.1, as with any later version I have tried
(3.3.3, 4.0.4, 4.0.5), trjconv -pbc clust  won't work at all, even with
cubic simulation boxes.  I have successfully used version 3.2.1 many times
for this purpose when dealing with cubic simulation boxes.

I have tried many different ways to get this to work, such as converting to
the compact representation before clustering.  Also, the frame where the
program is the first one where a lipid has moved over a periodic boundary,
when the system is viewed as the compact representation.  The same behaviour
occurs when that frame is dumped out as a .gro file and the program is run
on that file only.

Does anyone have any idea how to get this to work?  Any help would be much
appreciated!  Please let me know if you need more information about my
simulation set-up.

Daniel Parton

More information about the gromacs.org_gmx-users mailing list