[gmx-users] amber force field in Gromacs

servaas servaas.michielssens at student.kuleuven.be
Mon Nov 30 14:29:56 CET 2009


I tried using the amber force field in GROMACS. I proceeded as follows:
Determined my parameters with RED/ANTECHAMBER/tleap converted them with amb2gmx.pl 
(or with acpypi, problem is the same) to gromacs coordinate and topology files. It concerns a modified nucleotide. I minimized with steepest descent, everything was fine. 
When I tried running a simulation in single precision with this .mdp file (only nucleotide without solvent):

integrator       = md

dt               = 0.002
nsteps           = 250000
nstcomm  = 1

nstxout   = 1
nstvout   = 1
nstfout   = 0
nstlog    = 500
nstenergy = 1

nstlist          = 10
ns_type          = grid
rlist            = 1.2
coulombtype      = PME
rcoulomb         = 1.2
vdwtype          = cut-off
rvdw             = 1.2

fourierspacing   = 0.12
pme_order        = 4
ewald_rtol       = 1e-5

constraints      = all-bonds

;  temperature coupling is on
Tcoupl              = v-rescale
tau_t               = 0.1
tc-grps             = system
ref_t               = 300

pcoupl              = no

I get LINCS errors and eventually a crash. Now I tried running the same simulation with the same force field parameters in amber and everything was fine. 
I also ran the calculation in GROMACS with double precision here again everything was fine... I also tried running a small nucleic acid fragment (so no modified parameters here) 
that I created in  tleap and converted to GROMACS again this crashes with lincs errors in GROMACS. When I look at the trajectories it is the O4' of the ribose who clashes with the O3'. 

The fact that I still get this problem with non modified amber parameters makes me thing there is something wrong with my .mdp file to run with amber FF, any suggestions?
 Strange also that double precision seems to work just fine....

More information about the gromacs.org_gmx-users mailing list