[gmx-users] parallel simulations

Gavin Melaugh gmelaugh01 at qub.ac.uk
Wed Mar 3 17:18:49 CET 2010

Hi all

My apologies for the lack of  detail in my previous e-mail. I am trying
to run gromacs-4.0.7 for a system that I am studying. I have ran several
simulations on serial on my own computer that have to date worked fine.
I am now however trying to run the simulations on our local cluster in
parallel using mpich-1.2.7 and experiencing some difficulty. Please note
that the version of gromacs mentioned above is installed in parallel.
Right when I run a short simulation of 500 steps in one two or three
nodes the simulations
runs fine (takes about 10 seconds) and all the data is written to the
log file. However when I increase the nodes to 4 there is no stepwise
info written and the simulation does not progress. For clarity I have
attached the log file that iam getting for the 4 node simulation. I
realise that
this maybe a cluster problem, but if anyone has experienced similar
issues I would be grateful of some feedback.

Here is the script I use:

#PBS -N hex
#PBS -r n
#PBS -q longterm
#PBS -l walltime=00:30:00
#PBS -l nodes=4

export P4_GLOBMEMSIZE=100000000

/usr/local/bin/mpiexec mdrun -s

Also here is my path:
# Gromacs
export GMXLIB=/k/gavin/gromacs-4.0.7-parallel/share/gromacs/top
export PATH="$PATH:/k/gavin/gromacs-4.0.7-parallel/bin"



-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: md.log.4
URL: <http://maillist.sys.kth.se/pipermail/gromacs.org_gmx-users/attachments/20100303/c81925c4/attachment.ksh>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Deleted:
Type: text/x-moz-deleted
Size: 176 bytes
Desc: not available
URL: <http://maillist.sys.kth.se/pipermail/gromacs.org_gmx-users/attachments/20100303/c81925c4/attachment.bin>

More information about the gromacs.org_gmx-users mailing list