[gmx-users] issue with nsteps

David van der Spoel spoel at xray.bmc.uu.se
Wed May 5 19:15:35 CEST 2010

On 5/5/10 6:42 PM, DAVID DE SANCHO wrote:
> Dear all
> I am having a problem with a Gromacs run that I have prepared for a 
> total of 1e10 steps (actually nsteps=10000000000; this accounts in 
> this case for a total run time of 10 microseconds). When I run 
> "grompp" I see in the preprocessing output that apparently the correct 
> number of steps has been read. However once the parallel simulation 
> has started running using the tpr file produced in the log file it 
> reads "nsteps = 1410065408".
> It may be that (1) there is a maximum number of steps in gromacs and 
> for longer simulations one needs to concatenate different runs, or (2) 
> that the total simulation time is longer than the longest queue in my 
> cluster. I have tried  to rule out the second option by using the 
> shortest queue in our cluster. Obviously if nsteps depends on the 
> length of the queue, if run in the shorter queue the maximum nsteps 
> should be shorter. Also I have assigned the should I have observed 
> that nsteps is still 1410065408, so it seems that this problem is not 
> dependent on our queue system. Any ideas?
> Thanks for your help
> d.
> ------------------------------------------------------------------------
> Con las alertas de Hotmail no perderás detalle de tu correo. 
> ¡Contrátalo ya! <http://home.mobile.live.com/MobileAttach.mvc/?mkt=es-es>
Maximum integer is 2e9.

David van der Spoel, PhD, Professor of Biology
Dept. of Cell and Molecular Biology, Uppsala University.
Husargatan 3, Box 596,  	75124 Uppsala, Sweden
phone:	46 18 471 4205		fax: 46 18 511 755
spoel at xray.bmc.uu.se	spoel at gromacs.org   http://xray.bmc.uu.se/~spoel

More information about the gromacs.org_gmx-users mailing list