[gmx-users] Compile gromacs 4.0.7 with mopac

Stefan Hoorman stefhoor at gmail.com
Thu May 27 08:12:12 CEST 2010

I have been trying, unsuccessfully, to compile gromacs 4.0.7 with mopac7.
I have followed the following steps, which were adapted from dozens of sites
with instructions on how to do this.
I have downloaded mopac7 from http://sourceforge.net/projects/mopac7/.
Inside the fortran folder I have deleted deriv.f and moldat.f. Most of the
instructions name a third file, mopac.f which is not there (at least from
this tar.gz file I have downloaded). Instead there are two other files that
don t seem to make a difference whether I compile them with fortran or not
(I say that because I have tried creating libmopac.a with and without these
files and the outcome was the same).
Next I compiled all .f files with the command
f77 -O2 -c *.f
then created my libmopac.a with
ar rcv libmopac.a *.o
ranlib libmopac.a
Lots of warnings come on the screen when I type the f77 command line, such

"Warning on line 409: inconsistent calling sequences for me08b,
    arg 1: here complex variable, previously real variable.
    arg 2: here complex variable, previously real variable.
    arg 3: here complex variable, previously real variable."

Well, after that I copy my libmopac.a to my recently created gromacs-4.0.7
And then try compiling gromacs with
No problems there, but then when I type
Oh ho, there comes the problem
Lines and lines like this come out:
"fort77-7183-148.c:(.text+0x4e): undefined reference to `i_indx'
fort77-7183-148.c:(.text+0x66): undefined reference to `s_cmp'
fort77-7183-148.c:(.text+0x78): undefined reference to `s_wsfe'
fort77-7183-148.c:(.text+0xa2): undefined reference to `do_fio'
fort77-7183-148.c:(.text+0xa7): undefined reference to `e_wsfe'
fort77-7183-148.c:(.text+0xf6): undefined reference to `s_wsfe'
fort77-7183-148.c:(.text+0x105): undefined reference to `do_fio'
fort77-7183-148.c:(.text+0x119): undefined reference to `do_fio'
fort77-7183-148.c:(.text+0x143): undefined reference to `do_fio'
fort77-7183-148.c:(.text+0x157): undefined reference to `do_fio'
fort77-7183-148.c:(.text+0x17e): undefined reference to `do_fio'
fort77-7183-148.c:(.text+0x183): undefined reference to `e_wsfe' "

And the make process ends up with error.

"make[3]: ** [grompp] Error 1
make[3]: Leaving directory `/home/stef/Download/gromacs-4.0.7/src/kernel'
make[2]: ** [all-recursive] Error 1
make[2]: Leaving directory `/home/stef/Download/gromacs-4.0.7/src'
make[1]: ** [all] Error 2
make[1]: Leaving directory `/home/stef/Download/gromacs-4.0.7/src'
make: ** [all-recursive] Error 1 "

Has anyone successfully compiled gromacs 4.0.5 or 4.0.7 in 64bits
architecture with mopac?
Has anyone had this kind of problem before?
Has anyone solved it?
Thank you
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://maillist.sys.kth.se/pipermail/gromacs.org_gmx-users/attachments/20100527/f86d1732/attachment.html>

More information about the gromacs.org_gmx-users mailing list