[gmx-users] do we still have a do_dssp and dssp compatibility issue? thread: do_dssp failed to execute

Pradip Biswas biswas.pk at gmail.com
Sat Aug 6 20:08:44 CEST 2011

I encountered the exact same error with Gromacs-4.5  as posted by Sunita
Patel back in October 2010 and could not find any solution in the
gmx_thread. The error was:

Failed to execute command: /home/path-to-dssp -na dd3sOJn3 ddZl9dcf >
/dev/null 2> /dev/null

I found that the do_dssp fails to fork dssp as the latter does not recognize
the flag "-na" defined in do_dssp. The dssp code that I downloaded recently,
recognizes the only flags "-i", "-o", "-v", "-d" and "-h".

So, I just tweaked the "-na" flag in the do_dssp source code as follows and
the do_dssp and dssp combination worked fine for me.

sprintf(dssp,"%s %s %s %s > /dev/null %s",
  dptr,bDoAccSurf?"":"-na",pdbfile,tmpfile,bVerbose?"":"2> /dev/null");

replaced by:
sprintf(dssp,"%s %s %s %s > /dev/null %s",
  dptr,bDoAccSurf?"":"-i",pdbfile,"-o",tmpfile,bVerbose?"":"2> /dev/null");

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://maillist.sys.kth.se/pipermail/gromacs.org_gmx-users/attachments/20110806/5bc298b9/attachment.html>

More information about the gromacs.org_gmx-users mailing list