[gmx-users] 4.5.3 Installation under Cygwin

Mark Abraham mark.abraham at anu.edu.au
Mon Jan 31 07:29:43 CET 2011

On 01/31/11, toma0052 at umn.edu wrote:
> Hello,
>     I am trying to install gromacs 4.5.3 on my desktop under Cygwin. Using the installation procedure from the Wiki:
> (<http://www.gromacs.org/Downloads/Installation_Instructions/Cygwin_HOWTO>
> Install fftw-3.2.2 with ./configure --enable-sse --enable-float
> make
> make install
> Then install gromacs with:
> ./configure --enable-shared LDFLAGS='-L/usr/local/lib'
> make
> The installation fails here with many errors not being able to find libraries associated with fftw tracing back to this error:
> *** Warning: This system can not link to static lib archive /usr/local/lib/libfftw3f.la.
> *** I have the capability to make that library automatically link in when
> *** you link to this library.  But I can only do this if you have a
> *** shared version of the library, which you do not appear to have.
> The installation procedure from the Wiki works fine with gromacs-4.0.7. This error only occurs with the 4.5 series. Are there different default settings for where gromacs looks for fftw between 4.0.7 and 4.5.3? Any help would be appreciated.

I ran into the same issue a while back. I don't know what causes it. I found that using a CMake-based build on Cygwin worked.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://maillist.sys.kth.se/pipermail/gromacs.org_gmx-users/attachments/20110131/d77c3d97/attachment.html>

More information about the gromacs.org_gmx-users mailing list