[gmx-users] 4.5.3 Installation under Cygwin

toma0052 at umn.edu toma0052 at umn.edu
Mon Jan 31 23:52:36 CET 2011

     Thanks for the response. I tried building gromacs using cmake and the 
procedure from the wiki. Are there custom flags that I have to pass to 
cmake for it to work under cygwin? The cmake procedure seems to run fine 
without any errors, but I cannot evoke any gromacs tool following 
installation. I get the error:
$ g_energy -h
/usr/local/gromacs/bin/g_energy.exe: error while loading shared libraries: 
cyggmxana-6.dll: cannot open shared object file: No such file or directory

I found info on the mailing list related to the absence of DLLs, but the 
fix seemed to be applied to version 3.3.3

Is there something I am missing?


On Jan 31 2011, Mark Abraham wrote:

>On 01/31/11, toma0052 at umn.edu wrote:
>> Hello,
       I am trying to install gromacs 4.5.3 on my desktop under Cygwin. 
Using the installation procedure from the Wiki:
>> Install fftw-3.2.2 with ./configure --enable-sse --enable-float
>> make
>> make install
>> Then install gromacs with:
>> ./configure --enable-shared LDFLAGS='-L/usr/local/lib'
>> make
   The installation fails here with many errors not being able to find 
libraries associated with fftw tracing back to this error:
   *** Warning: This system can not link to static lib archive 
>> *** I have the capability to make that library automatically link in when
>> *** you link to this library.  But I can only do this if you have a
>> *** shared version of the library, which you do not appear to have.
   The installation procedure from the Wiki works fine with gromacs-4.0.7. 
This error only occurs with the 4.5 series. Are there different default 
settings for where gromacs looks for fftw between 4.0.7 and 4.5.3? Any help 
would be appreciated.
 I ran into the same issue a while back. I don't know what causes it. I 
found that using a CMake-based build on Cygwin worked.

More information about the gromacs.org_gmx-users mailing list