[gmx-users] problems when using trjconv or g_msd to process xtc trajectory files with only a portion of all the atoms in the system

rocwhite168 rocwhite168 at 163.com
Mon Jul 30 06:23:06 CEST 2012

Dear Gromacs users,

I tried to use "g_msd -s topol.tpr -f traj.xtc -o msd.xvg -trestart
500" to calculate the mean-squared displacements. But the results are
clearly erroneous: the first 2500 entries in the output are all
"-nan", and after that values stat constant (including zeros). I
suspected that this may be related to that I have too many frames
(20001) and too long simulation length (20 ns), so I tried to reduce
them with the command "trjconv -f traj.xtc -s topol.tpr -b 0 -e 1000
-o traj.1ns.xtc" to split the trajectory file, but trjconv exited with
an error like "Index[0] 1234 is larger than the number of atoms in the
trajectory file (12). There is a mismatch in the contents of your -f,
-s and/or -n files."

Now I think both problems may be due to the fact that only a portion
of all the atoms in the system have been written to the trajectory,
and other atoms are kept fixed. But I am fairly new to Gromacs, and
I'm wondering if I have missed anything.



More information about the gromacs.org_gmx-users mailing list