[gmx-users] Extending simulation problem.

Dawid das addiw7 at googlemail.com
Fri Aug 22 14:49:04 CEST 2014

Can you just have a quick look at this?
When I run:
tpbconv -s npt-md.tpr -extend 95000 -o npt-md.tpr

to extend simulation by 95 ns this time I got this message at the end:

Extending remaining runtime of by 95000 ps (now 50000000 steps)
Writing statusfile with starting step          0 and length   50000000
                                 time      0.000 and length 100000.000 ps

So it looks like new status file is written and it says that simulation
will start from the very beginning or did I misunderstand something?
However when I check state.cpt with gmxdump it looks fine:

step = 2500000
t = 5000.000000

as I expect.

Thank you,


2014-08-22 13:15 GMT+01:00 Dawid das <addiw7 at googlemail.com>:

> 2014-08-21 17:45 GMT+01:00 Mark Abraham <mark.j.abraham at gmail.com>:
> > Well in my *log file nothing about state or *cpi files is mentioned.
>> >
>> Sounds like perhaps your combination of circumstances (-append, no old
>> output files provided for appending, maybe not even a checkpoint file
>> provided) is leading to mdrun silently doing the only thing it can do,
>> which is start again from either the -s or -cpi state. Your description
>> of "I
>> tried both state.cpt and prev_state.cpt and the beginning of new
>> simulation
>> looks exactly the same" doesn't help fully - same as what? The start of
>> the
>> first simulation, or the end of the first simulation?
> It is exactly the same as the start of the first simulation. Like I said,
> I did not have appropriate files from previous simulation in my scratch
> and I rerun it incorrectly I guess.
> Thank you for your detailed answer :). I think I will manage now to extend
> this simulation properly.

More information about the gromacs.org_gmx-users mailing list