[gmx-users] Problem with the MDS extended trajectory in Gromacs 5.04

PAULAMI CHATTERJEE chatterjee_paulami at yahoo.co.in
Thu Jul 9 21:15:17 CEST 2015

I have used the following commands for the initial mdrun
gmx grompp -f md.mdp -c npt.gro -t npt.cpt -p topol.top -o md_0_1.tprgmx mdrun -deffnm md_0_1 
Can you please suggest now what went wrong?


     On Thursday, 9 July 2015 5:12 PM, Justin Lemkul <jalemkul at vt.edu> wrote:


On 7/9/15 4:15 AM, PAULAMI CHATTERJEE wrote:
> Dear All,
> I have a 30 ns trajectory which I would like to extend up to 100 ns. For that I gave the following commands
> gmx convert-tpr -s md_0_1.tpr -extend 70000 -o final_monomer.tpr
> gmx mdrun -s final_monomer.tpr -cpi md_0_1.cpt -append
> After completion of the extension two new trajectory files were generated- 'traj.trr' and 'traj_comp.xtc' . When I tried to check the length of the trajectory with
> gmxcheck -f traj_comp.xtc
> the output is
> Checking file traj_comp.xtc
> Reading frame 0 time 30000.000
> # Atoms 16867
> Precision 0.001 (nm)
> Last frame 35000 time 100000.000
> This trajectory file contains coordinate values from 30ns to 100ns. I tried to calculate the rmsd with this file (both the trr and xtc file) but the graph abruptly starts from 30ns (instead of 0) and continues upto 100ns.For the calculation I need the total trajectory from time 0 to time 100ns.I think I am missing something.

Indeed, you're missing your first trajectory.

You specified -append but if you're changing file names then that won't happen 
and you need to use trjcat afterwards.  But since you haven't told us what the 
initial mdrun command was, there's no way to say what's going on for sure.



Justin A. Lemkul, Ph.D.
Ruth L. Kirschstein NRSA Postdoctoral Fellow

Department of Pharmaceutical Sciences
School of Pharmacy
Health Sciences Facility II, Room 629
University of Maryland, Baltimore
20 Penn St.
Baltimore, MD 21201

jalemkul at outerbanks.umaryland.edu | (410) 706-7441



More information about the gromacs.org_gmx-users mailing list