[gmx-users] about g_wham command of gromacs

凌未风 grx1985 at qq.com
Tue Sep 1 23:09:29 CEST 2015


I have a strange problem when I use g_wham to generate free energy profiles based on umbrella sampling (US) results. 

I have about ~30 windows of US simulations, 3 microseconds for each window, saved every 10 ps in the pullf.xvg files. When I try to generate the energy profiles, g_wham could not read the data in pull.xvg files after ~ 2.5 microseconds. When I use "g_wham -b 2500000", the program gives an error of no data, when I use "g_wham -b 0", it could generate reasonable profiles, but when I check the result, I found g_wham only reads data before ~2.5 microseconds.
I double checked my pullf.xvg files, I am pretty sure there are "enough"  data in the files, and there is no break in the data. I also asked other colleagues in my lab as well as collaborators to help to check my data. We could not find where is wrong. 

I also tried the following things:

1, devided the time by 1000 in the pullf.xvg file, so the number of the time is not so large. It did not work. 
2, calculate distances between groups based on trajectories, then change the format to "pdo". In one case, it worked, but in the other cases, it did not work. 

I am wondering if any one has the same problem. Did I do something wrong or this is a bug of g_wham?

example of data is available upon request. Any help is highly appreciate. 

Thanks very much. 
Ruo-Xu Gu
University of Calgary

More information about the gromacs.org_gmx-users mailing list