[gmx-users] gromacs 5.1.2 mdrun can't detect GPU

Téletchéa Stéphane stephane.teletchea at univ-nantes.fr
Thu Apr 21 23:39:13 CEST 2016

Le 21/04/2016 03:54, treinz a écrit :
> Hi,
> Can you also explain why the function calls to cudaDriverGetVersion() and cudaRuntimeGetVersion() both return 0, as in
>>> >>CUDA driver:        0.0
>>> >>CUDA runtime: 0.0
> Thanks,
> Tim

Hi all,

As I already posted on the list, it seems the combination of gromacs + 
cuda is tedious,
I had not time to dig it further, but wrote down what worked for me:


The driver version was very close from the drivers included in the 
default ubuntu
installation, nvidia-smi was working fine also, but gromacs was not able 
to detect it.

Using the driver from the cuda toolkit solved the problem for me.
I only sent a mail on the mailing list, if I have time to dig further 
I'll try to provide more
insight and a proper bug report. Up to now you can check if the driver 
version is the one
expected from the cuda toolkit (nvidia-smi -a).



Assistant Professor in BioInformatics, UFIP, UMR 6286 CNRS, Team Protein Design In Silico
UFR Sciences et Techniques, 2, rue de la Houssinière, Bât. 25, 44322 Nantes cedex 03, France
Tél : +33 251 125 636 / Fax : +33 251 125 632
http://www.ufip.univ-nantes.fr/  -http://www.steletch.org

More information about the gromacs.org_gmx-users mailing list