[gmx-users] tip4p2005 with gromacs 4.6.5

Irem Altan irem.altan at duke.edu
Thu Feb 18 00:29:57 CET 2016

Thanks! It solved most of the problem.
I am now getting an error during energy minimization:

The [molecules] section of your topology specifies more than one block of
a [moleculetype] with a [settles] block. Only one such is allowed. If you
are trying to partition your solvent into different *groups* (e.g. for
freezing, T-coupling, etc.) then you are using the wrong approach. Index
files specify groups. Otherwise, you may wish to change the least-used
block of molecules with SETTLE constraints into 3 normal constraints.
For more information and tips for troubleshooting, please check the GROMACS
website at http://www.gromacs.org/Documentation/Errors

I am in fact labeling water molecules separately, but this had worked before with TIP4P.

my topology file looks like this:

; Include forcefield parameters
#include "./amber99sb.ff/forcefield.itp"

; Include chain topologies
#include "topol_Protein_chain_A.itp"
#include "topol_Protein_chain_B.itp"
#include "topol_Other_chain_A2.itp"
#include "topol_Other_chain_B2.itp"

; Include water topology
#include "./amber99sb.ff/tip4p2005.itp"

; Position restraint for each water oxygen
[ position_restraints ]
;  i funct  fcx        fcy        fcz
   1    1 1000    1000       1000

; Include topology for ions
#include "./amber99sb.ff/ions.itp"
#include "./tip4p2005cw.itp"

[ system ]
; Name
Protein in water

[ molecules ]
; Compound        #mols
Protein_chain_A     1
Protein_chain_B     1
Other_chain_A2      1
Other_chain_B2      1
HO4                96
HO4                62
SOL         5763
NA               6
CL               10

where tip4p2005cw.itp has the molecule name defined as HO4:

[ moleculetype ]
; molname    nrexcl
  HO4        2

Does this somehow clash with TIP4P’s HO4? Do I need to name it differently?

On Feb 17, 2016, at 5:48 PM, Justin Lemkul <jalemkul at vt.edu<mailto:jalemkul at vt.edu>> wrote:

On 2/17/16 5:41 PM, Irem Altan wrote:

I would like to use TIP4P2005 with Gromacs 4.6.5 for a protein simulation with water. I have the .itp and .gro files for the model.
I am using a slightly modified version of the Amber forcefields, so I have a folder called amber99sb.ff in my working directory. I have added a file called tip4p2005.itp into that folder. I then tried the following:

pdb2gmx -f amber99sb.ff/ -water tip4p2005.itp -o box.gro -p topol.top

as well as

pdb2gmx -f amber99sb.ff/ -water tip4p2005 -o box.gro -p topol.top

both of which result in an error saying “invalid argument tip4p2005(.itp) for option -water”.

How can I get this to work?

It must match the first field of an entry in watermodels.dat in the force field directory.

Also note that pdb2gmx -f takes a coordinate file, not a directory name.  That will cause a whole host of failures...



Justin A. Lemkul, Ph.D.
Ruth L. Kirschstein NRSA Postdoctoral Fellow

Department of Pharmaceutical Sciences
School of Pharmacy
Health Sciences Facility II, Room 629
University of Maryland, Baltimore
20 Penn St.
Baltimore, MD 21201

jalemkul at outerbanks.umaryland.edu<mailto:jalemkul at outerbanks.umaryland.edu> | (410) 706-7441

Gromacs Users mailing list

* Please search the archive at http://www.gromacs.org/Support/Mailing_Lists/GMX-Users_List before posting!

* Can't post? Read http://www.gromacs.org/Support/Mailing_Lists

* For (un)subscribe requests visit
https://maillist.sys.kth.se/mailman/listinfo/gromacs.org_gmx-users or send a mail to gmx-users-request at gromacs.org<mailto:gmx-users-request at gromacs.org>.

More information about the gromacs.org_gmx-users mailing list