[gmx-users] Error when for gmx tune_pme on Cray

Mark Abraham mark.j.abraham at gmail.com
Tue Apr 10 17:22:30 CEST 2018


On Tue, Apr 10, 2018 at 4:52 PM Viveca Lindahl <vivecalindahl at gmail.com>

> @Carsten: thanks for the suggestions. I needed the 'aprun -n 1' to be able
> to run  with my mpi-binary (otherwise I get 'illegal instruction'). I now
> tried
> export MPIRUN=aprun; $gmx tune_pme -npstring n -s topol.tpr -np 16 -mdrun
> $gmx_mpi
> where gmx/gmx_mpi are a thread-mpi/real MPI builds and get
> Fatal error:
> Need an MPI-enabled version of mdrun. This one
> (/cfs/klemming/nobackup/v/vivecal/programs/gromacs/2018.1/bin/gmx)
> seems to have been compiled without MPI support.
> referring to the mpi build.

It's tried out what you supplied to the -mdrun flag and found it didn't
work. Probably for the reason below.

> @Mark: Do you mean that tune_pme expects the binaries to have exactly these
> names gmx/gmx_mpi  (and be in the same location)?

No, but checking out gmx help tune_pme regarding -mdrun would help you
provide what is needed, e.g. "gmx_mpi mdrun" (modulo however you built and
suffixed your gmx binaries).


More information about the gromacs.org_gmx-users mailing list