[gmx-users] append does not work for me

Michael Brunsteiner mbx0009 at yahoo.com
Wed Apr 22 22:26:13 CEST 2015

On 4/21/15 10:41 AM, Michael Brunsteiner wrote:
>> Hi,
>> I just tried to continue a simulation, after having extended the total time using
>> gmx convert-tpr -s original-xxx.tpr -o xxx.tpr -until 400000
>> mdrun -nt 4 -deffnm xxx -cpi xxx.cpt
>> xxx.cpt, xxx.log, and xxx.trr are present  in the working directory and are
>> the original output files, i.e., they were NOT modified
>> but instead of appending the new data gmx makes backups of theoriginal files (i.e. renames xxx.* to #xxx.*.1#)>> and writes the data into new files xxx.*>> this happens both with without the -append option to mdrun ...
>> the original files were produced with gmx 5.0.1 and for the extensioni tried to use gmx 5.0.4 ... can this be the problem?>>if so, is there a work around?>> other than using trjcat, which is tedious as here i am working with HUGE files...>
> Did you enable large file support when you compiled GROMACS?
no ... i wasn;'t aware there is such a thing ... some google-ing suggeststhat the limit is as low as 2Gb ... is that still true for gmx 5.0 ? ... and is it truethat a checkpoint file written with an mdrun compiled without large file support 
and for a trr filesize greater than 2Gb cannot be used for a run continuation? 
is there no work around for that ??

>  Or maybe the file size is an OS limit?

the trajectory files are about 20 Gb, which my 64 bit linux sould be able to handle ...
thanks for the hint!michael


More information about the gromacs.org_gmx-users mailing list