[gmx-users] Gromacs 5.1.2 installation problem

James Graham J.A.Graham at soton.ac.uk
Tue Apr 5 11:11:06 CEST 2016

Hi Husen,

In GROMACS version 5.1 the default program naming scheme was changed so 
that everything is now part of the executable 'gmx'.  Because of this 
you need to use 'gmx pdb2gmx' (and e.g. 'gmx grompp', 'gmx mdrun') instead.

The change was actually made in version 5.0, but they left an option to 
use it the old way as well.


On 05/04/16 08:19, Husen R wrote:
> Dear all,
> I already installed gromacs-5.1.2 succesfully with the following
> instruction :
> tar xfz gromacs-5.1.2.tar.gz
> cd gromacs-5.1.2
> mkdir build
> cd build
> make
> make check
> sudo make install
> source /usr/local/gromacs/bin/GMXRC
> However, after finishing installation I can not use mdrun, pdb2gmx
> (and possibly other commands).
> The following is the error message when I tried to run pdb2gmx command.
> The program 'pdb2gmx' is currently not installed. You can install it by typing:
> sudo apt-get install gromacs
> I tried to find those commands using "locate" command but they're
> doesn't exist as if gromacs is not installed.
> Note : The installation directory /usr/local/gromacs is exist.
> anyone please tell me what will be the cause of this problem ?
> Regards,
> Husen

James Graham - PhD Student
Institute for Complex Systems Simulation (ICSS)
Computational Systems Chemistry
University of Southampton, UK

More information about the gromacs.org_gmx-users mailing list