[gmx-users] GPU not found

Albert mailmd2011 at gmail.com
Tue May 13 12:42:11 CEST 2014

Now the problem solved now after I reinstall NVIDIA driver. When I run in
single GPU, it works fine. However, when I try to run :

mpirun -np 2 mdrun_mpi -s test.tpr

it failed with messages:
[mpiexec at cudaA.compuBio] HYDU_getfullhostname
(./utils/others/others.c:136): getaddrinfo error (hostname: cudaA.compuBio,
error: Name or service not known)
[mpiexec at cudaA.compuBio] HYDU_sock_create_and_listen_portstr
(./utils/sock/sock.c:999): unable to get local hostname
[mpiexec at cudaA.compuBio] HYD_pmci_launch_procs
(./pm/pmiserv/pmiserv_pmci.c:313): unable to create PMI port
[mpiexec at cudaA.compuBio] main (./ui/mpich/mpiexec.c:877): process manager
returned error launching processes

I am using intel mpi...........

thank you very much.


2014-05-13 11:54 GMT+02:00 Mirco Wahab <mirco.wahab at chemie.tu-freiberg.de>:

> On 13.05.2014 11:18, Albert wrote:
>> I compiled Gromacs in a GPU machine with two GTX780Ti with following
>> command:
>> env CC=icc F77=ifort CXX=icpc
>> CMAKE_PREFIX_PATH=/soft/intel/mkl/include/fftw:/soft/intel/impi/
>> cmake ..
>> -DCUDA_TOOLKIT_ROOT_DIR=/usr/local/cuda
>> however, when I try to run some jobs, it failed with messages:
>> NOTE: Error occurred during GPU detection:
>>        no CUDA-capable device is detected
>>        Can not use GPU acceleration, will fall back to CPU kernels.
>>  What does
> $> nvidia-smi
> on this machine print out?
> see: http://manpages.ubuntu.com/manpages/natty/man1/alt-
> nvidia-current-smi.1.html
> --
> Gromacs Users mailing list
> * Please search the archive at http://www.gromacs.org/
> Support/Mailing_Lists/GMX-Users_List before posting!
> * Can't post? Read http://www.gromacs.org/Support/Mailing_Lists
> * For (un)subscribe requests visit
> https://maillist.sys.kth.se/mailman/listinfo/gromacs.org_gmx-users or
> send a mail to gmx-users-request at gromacs.org.

More information about the gromacs.org_gmx-users mailing list