[gmx-users] GPU not found

Mirco Wahab mirco.wahab at chemie.tu-freiberg.de
Tue May 13 13:13:14 CEST 2014

On 13.05.2014 12:42, Albert wrote:
> Now the problem solved now after I reinstall NVIDIA driver. When I run in
> single GPU, it works fine. However, when I try to run :
> mpirun -np 2 mdrun_mpi -s test.tpr
> it failed with messages:
> [mpiexec at cudaA.compuBio] HYDU_getfullhostname
> (./utils/others/others.c:136): getaddrinfo error (hostname: cudaA.compuBio,
> error: Name or service not known)
> [mpiexec at cudaA.compuBio] HYDU_sock_create_and_listen_portstr
> (./utils/sock/sock.c:999): unable to get local hostname
> [mpiexec at cudaA.compuBio] HYD_pmci_launch_procs
> (./pm/pmiserv/pmiserv_pmci.c:313): unable to create PMI port
> [mpiexec at cudaA.compuBio] main (./ui/mpich/mpiexec.c:877): process manager
> returned error launching processes

I'm not familiar with Intel MPI.
(Why do you see importance in using the Intel tools at all?)

But on OpenMPI, there would be a cmd line option
specifying the host where the processes are
supposed to run on. I'm sure there is an equiv.
option with the Intel suite.

What is the output of
$> echo `hostname`

Is the MPI using ssh or rsh? Can the
machine ssh/rsh into itself? By using
which hostname?



More information about the gromacs.org_gmx-users mailing list